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Issue
You have deployed a virtual appliance (VA), but it is not showing up in the Umbrella Dashboard under Deployment > Configuration > Sites & Active Directory. Additionally, the virtual appliance's console displays the sync process as disabled and that the Updates test has failed, as shown below:
Tabbing over to the Updates: GET failed test and pressing Enter reveals the following information:
GET failed: GET from http://shared.opendns.com:80/enterprise/upgrade/va/mainline/MANIFEST failed: HTTP/1.1 404 Not Found
Resolution
If you are deploying your virtual appliances in VMWare and witness the behavior described above, do not make any changes to the OVA file archive or the OVF template included in that archive. Deploy the OVF template exactly as it is shown in the Cisco Umbrella documentation.
If you are deploying the virtual appliances in Hyper-V, please pay special attention to the section around importing both hard disks as shown in the Cisco Umbrella documentation.
Cause
The behavior described earlier indicates that the virtual appliances were not deployed according to the existing documentation.
The virtual appliances are downloaded from the Umbrella Dashboard as file archives (.ova for VMWare, .zip for Hyper-V). Extracting from these archives should reveal the following files:
VMWare:
-
forwarder-va.vmdk (hard disk)
-
dynamic.vmdk (hard disk)
-
forwarder-va.ovf (descriptor file)
-
forwarder-va.mf (manifest file)
Hyper-V:
- Virtual Hard Disks\forwarder-va.vhd (hard disk)
- Virtual Hard Disks\dynamic.vhd (hard disk)
- config.xml (configuration file)
- Virtual Machines\[ALPHANUMERIC STRING].exp (export file)
The first hard disk listed for each platform, forwarder-va.vmdk and forwarder-va.vhd, contains the DNS forwarder software that takes in client DNS queries and forwards them to Umbrella Anycast resolvers. This disk also contains the sync process that periodically checks in with the Umbrella API.
The second hard disk listed for each platform, dynamic.vmdk and dynamic.vhd, contain organization-specific information that is required by the virtual appliance's sync process. If the virtual appliance's sync process located on the forwarder-va hard disk does not have the information on the dynamic disk available, then it is unable to sync with the Umbrella API, and the process remains disabled. Additionally, the virtual appliance never registers with the Umbrella Dashboard, and it will continue to fail the Updates test shown in the earlier screenshots.