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Overview
This article is directed at users who are not seeing their Meraki profile appear in the Umbrella mobile devices "Link to Meraki" function. Linking to Meraki is the first step in using the iOS Cisco Security Connector (CSC) with the Meraki MDM.
Symptoms
The most common symptom is that the expected target Meraki MDM profile does not appear when linking to Meraki from Umbrella. A 403 error toast message at the bottom of the screen may also be generated. This would appear as the desired policy not appearing in the highlighted area shown below. For example, see below. It may also appear as a blank list.
Root cause
In most cases, the root cause is due to one of the following two causes:
- Meraki API key is incorrect. Please validate your API key from your Meraki Dashboard. Go to the main page, and click your username at the top right, then select "My Profile". Your API key is listed on this page.
- Meraki API key does not have sufficient API access. To validate, follow the steps below.
- From within the Meraki Dashboard, navigate to 'Help > API
Docs' at the top right of the page. - Does the 'List all the profiles in the network' subsection appear in the API Docs? If not, then your account does not have access to this call and this must be resolved on the Meraki side. One common cause is that automated free trials do not receive this access.
- No access example:
- Access example:
- No access example:
- From within the Meraki Dashboard, navigate to 'Help > API
Conclusion
When Meraki profiles do not appear on the Mobile Devices Meraki link MDM page, the root cause is typically associated with the Meraki API key used. Since Cisco Umbrella is pulling profile data from Meraki using the user's API key to this API call, we may only return what the key has access to see. Any 403 access errors from the Umbrella dashboard would be expected if the "List all the profiles in the network" API call is not allowed on an account.